By default, the Infragistics Version Utility does not upgrade the assemblies of your VS .Net project or solution from CLR 2.0 to 4.0 automatically. But you can do this via the „custom upgrade“ link.

In my case, I always got errors like

No matching assembly located in available assemblies Infragistics2.Win.UltraWinGrid.v12.1

Solution:

Look into your program filesInfragistics directory if this file (DLL and XML) exists. Then run the upgrade again and enter the path to the 4.0 assemblies manually:

Now the upgrade should work.

  [email protected]